- Inter-VLAN Communication Using an External Router: Router-on-a-Stick
- Inter-VLAN Communication Tips
- Inter-VLAN Communication on a Multilayer Switch Through a Switch Virtual Interface
- Configuration Example: Inter-VLAN Communication
- Configuring DHCP Server on a Router or Layer 3 Switch
- Verifying and Troubleshooting DHCP Configuration
- Configuring a DHCP Helper Address
- DHCP Client on a Cisco IOS Software Ethernet Interface
- Configuration Example: DHCP
- Configuring Cisco Express Forwarding
- Verifying CEF
- Troubleshooting CEF
Inter-VLAN Communication on a Multilayer Switch Through a Switch Virtual Interface
Rather than using an external router to provide inter-VLAN communication, a multilayer switch can perform the same task through the use of a switched virtual interface (SVI).
Removing L2 Switchport Capability of a Switch Port
3750Switch(config)#interface fastethernet 0/1 |
Moves to interface configuration mode. |
3750Switch(config-if)#no switchport |
Creates a Layer 3 port on the switch. |
NOTE: The no switchport command can be used on physical ports only on a Layer 3–capable switch. |
Configuring SVI Autostate
3750Switch(config)#interface fastethernet 0/1 |
Moves to interface configuration mode. |
3750Switch(config-if)#switchport auto-state exclude |
Excludes the access port/trunk in defining the status of an SVI as up or down. |
NOTE: This command is commonly used for ports that are used for monitoring, for example, so that a monitoring port does not cause the SVI to remain "up" when no other ports are active in the VLAN. |
Configuring a Layer 3 EtherChannel
Switch(config)#interface port-channel 1 |
Creates a virtual Layer 2 interface. |
Switch(config-if)#no switchport |
Changes interface to Layer 3 to enable the use of the IP address command. |
Switch(config-if)#ip address 172.32.52.10 255.255.255.0 |
Assigns an IP address to the Layer 3 port-channel interface. |
Switch(config)#interface range fastethernet 5/4 - 5 |
Moves to interface range configuration mode. |
Switch(config-if-range)#no switchport |
Creates Layer 3 ports on a switch. |
Switch(config-if-range)#channel-protocol pagp |
Configures port aggregation protocol. |
Switch(config-if-range)#channel-group 1 mode desirable |
Assigns the physical interfaces in the range to the EtherChannel group. |
Configuring Inter-VLAN Communication
3550Switch(config)#interface vlan 1 |
Creates a virtual interface for VLAN 1 and enters interface configuration mode. |
3550Switch(config-if)#ip address 172.16.1.1 255.255.255.0 |
Assigns IP address and netmask. |
3550Switch(config-if)#no shutdown |
Enables the interface. |
3550Switch(config)#interface vlan 10 |
Creates a virtual interface for VLAN 10 and enters interface configuration mode. |
3550Switch(config-if)#ip address 172.16.10.1 255.255.255.0 |
Assigns IP address and netmask. |
3550Switch(config-if)#no shutdown |
Enables the interface. |
3550Switch(config)#interface vlan 20 |
Creates a virtual interface for VLAN 20 and enters interface configuration mode. |
3550Switch(config-if)#ip address 172.16.20.1 255.255.255.0 |
Assigns IP address and netmask. |
3550Switch(config-if)#no shutdown |
Enables the interface. |
3550Switch(config-if)#exit |
Returns to global configuration mode. |
3550Switch(config)#ip routing |
Enables routing on the switch. |